User Tools

Site Tools


doc:appunti:linux:sa:postgresql_upgrade

Differences

This shows you the differences between two versions of the page.

Link to this comparison view

Both sides previous revision Previous revision
doc:appunti:linux:sa:postgresql_upgrade [2020/03/02 17:48]
niccolo [Upgrade cluster from 9.6 to 11]
doc:appunti:linux:sa:postgresql_upgrade [2020/04/01 15:47] (current)
niccolo [Upgrade strategy]
Line 40: Line 40:
 The **pg_upgradecluster** can safely upgrade standard databases, but the relative manpage clearly states that: //Some PostgreSQL extensions like PostGIS need metadata in auxiliary tables which must not be upgraded from the old version, but rather initialized for the new version before copying the table data//. The **pg_upgradecluster** can safely upgrade standard databases, but the relative manpage clearly states that: //Some PostgreSQL extensions like PostGIS need metadata in auxiliary tables which must not be upgraded from the old version, but rather initialized for the new version before copying the table data//.
  
-We have several standard (non-GIS) databases and a few PostGIS-enabled ones, so our strategy will be:+We have several standard (non-GIS) databases and a few PostGIS-enabled ones. You can see if the PostGIS extension is enabled issuing the **\dx** once connected to the database. So our strategy will be:
  
   - **Dump** the PostGIS-enabled databases into files.   - **Dump** the PostGIS-enabled databases into files.
doc/appunti/linux/sa/postgresql_upgrade.txt ยท Last modified: 2020/04/01 15:47 by niccolo