User Tools

Site Tools


Sidebar

No ai soldati italiani all'estero

Indice

Eventi

Energia

Rigacci.Org usa energia elettrica da fonti rinnovabili, grazie al gruppo di acquisto Merci Dolci.

Merci Dolci - Energia Rinnovabile

Software libero!

Petizione contro i brevetti software

Faunalia: Soluzioni GIS professionali

Debian

www.gnu.org www.kernel.org

doc:appunti:linux:sa:egroupware

eGroupware

Aggiornamento di eGroupware dalla versione 1.4 alla versione 1.8.004. Istruzioni sintetiche qui: ManualSetupUpdate.

Si rinomina /var/www/egroupware/, si scarica da Sourceforge i seguenti archivi:

  • eGroupware-1.8.004.20130322.zip
  • eGroupware-egw-pear-1.8.004.20130322.zip

e si scompattano in /var/www/egroupware/.

Requisiti installazione

Visitare https://<host>/egroupware/setup/, fare accesso come Setup/Config Admin Login e cliccare su Check installation per verificare che i requisiti di installazione siano soddisfatti.

Verificare che siano installati i pacchetti Debian:

  • php-pear
  • php5-sqlite
  • php-auth-sasl
  • php-xml-parser (non risolve)
  • php-xml-rss (non risolve)
  • tnef

Si ottiene questo warning:

Checking PEAR::XML_Feed_Parser is installed: False
PEAR::XML_Feed_Parser is needed by: NewsAdmin. You can install it by running: pear install XML_Feed_Parser

per risolvere installare da riga di comando:

pear install XML_Feed_Parser

Installare jpgraph_3.0.7-1_all.deb scaricato dal repository download.opensuse.org, directory eGroupWare/Debian_6.0. Questo perché il pacchetto Debian libphp-jpgraph è una versione troppo vecchia.

php.ini

Controllare /etc/php5/apache2/php.ini:

upload_max_filesize = 8M
mbstring.func_overload = 7
date.timezone = Europe/Rome

L'impostazione mbstring.func_overload potrebbe causare conflitti con altri gestori di contenuti (ad es. Joomla). Per evitare problemi si può limitare la configurazione alla sola path di eGroupware:

<Location /egroupware>
        php_admin_value mbstring.func_overload 7
</Location>

Aggiornamento database e verifica

Visitare https://<host>/egroupware/setup/.

Accedere come Header Admin Login. Se necessario resettare la password in /var/www/egroupware/header.inc.php:

$GLOBALS['egw_info']['server']['header_admin_password'] = 'here will be the MD5 Encoded Password';

Quindi si sceglie di aggiornare header.inc.php.

Accedere come Setup/Config Admin Login, aggiornare il database.

Durante l'aggiornamento bisogna creare alcune directory (perché non si è installato il pacchetto, ma dai sorgenti):

mkdir -p /var/lib/egroupware/default/backup
chown www-data:www-data /var/lib/egroupware/default/backup
mkdir -p /var/lib/egroupware/default/files
chown www-data:www-data /var/lib/egroupware/default/files

Il processo di aggiornamento rileva alcuni problemi: “following applications need to be upgraded: tracker, notifywindow, mydms”.

Tuttavia due moduli non sono più presenti in eGroupware e vanno rimossi: mydms e notifywindow.

doc/appunti/linux/sa/egroupware.txt · Last modified: 2013/04/15 09:47 by niccolo