User Tools

Site Tools


Sidebar

No ai soldati italiani all'estero

Indice

Eventi

Energia

Rigacci.Org usa energia elettrica da fonti rinnovabili, grazie al gruppo di acquisto Merci Dolci.

Merci Dolci - Energia Rinnovabile

Software libero!

Petizione contro i brevetti software

Faunalia: Soluzioni GIS professionali

Debian

www.gnu.org www.kernel.org

Altre libertà

MoVimento 5 Stelle Campi Bisenzio

tecnica:gps_cartografia_gis:debian_install

Installazione software GIS su Debian

DELETEME ATTENZIONE: gran parte di questi appunti sono obsoleti. Per installare il software sotto riportato su una Debian Lenny o una Debian Squeeze si possono utilizzare i pacchetti forniti dalla distribuzione oppure utilizzare dei backport, ad esempio quelli di http://debian.gfoss.it/.

Pacchettizzazione Debian

GRASS

DebianGis ha il suo SVN. I Debian files di GRASS provengono da uno di questi rami SVN:

svn export svn://svn.debian.org/pkg-grass/packages/grass/branches/6.2.0/debian
svn export svn://svn.debian.org/pkg-grass/packages/grass/tags/6.2.1-1/debian/
svn export svn://svn.debian.org/pkg-grass/packages/grass/trunk/debian/

Attualmente (2007-03-27) il trunk principale va bene per compilare grass 6.2.1 su Debian Etch.

Required packages

Aggiornamento 2006-01-15.

Server

Software Package Apt source Install Latest Note
PostgreSQL postgresql-8.1 Debian Etch 8.1 8.1 SQL Database
PostGIS libpostgis1-pg8.1_1.1.0 Debian-GIS 1.1.0 1.1.0 Adds support for geographic objects to the PostgreSQL database
PROJ proj Debian Etch 4.4.9 4.4.9 Cartographic projection filter and library
GEOS libgeos2c2a Debian Etch 2.1.4 2.2.1 Geometry Engine: C++ spatial functions and operators
GDAL libgdal1c2a Debian Etch 1.2.6 1.3.1 1) Geospatial Data Abstraction Library is a translator library for raster geospatial data formats
OGR gdal-bin Debian Etch 1.2.6 1.3.1 2) Geospatial Data Abstraction Library - Utility programs
MapServer cgi-mapserver Debian Etch 4.6.1 4.6.2 Environment for building spatially-enabled internet applications

Workstation

Software
GRASS
QGIS
Gpsbabel, Gpsman, Gpsmanshp, Gpstrans
qgis-plugin-grass

2005-11-06 Debian Etch

We get some packages on-hold:

Package Holded version My be replace with
libpq3 7.4.7-6sarge1 libpq3 1:7.4.8-17 testing
postgresql 7.4.7-6sarge1 postgresql-7.4 1:7.4.8-17 testing
postgresql-client 7.4.7-6sarge1 postgresql-client-7.4 1:7.4.8-17 testing
postgresql-contrib 7.4.7-6sarge1 postgresql-contrib-7.4 1:7.4.8-17 testing

mapserver 4.6

Got and installed the following packages from Unstable:

  • cgi-mapserver_4.6.1-4_i386.deb
  • cpp-4.0_4.0.2-3_i386.deb
  • g++-4.0_4.0.2-3_i386.deb
  • gcc-4.0-base_4.0.2-3_i386.deb
  • gcc-4.0_4.0.2-3_i386.deb
  • libgcc1_4.0.2-3_i386.deb
  • libstdc++6-4.0-dev_4.0.2-3_i386.deb
  • libstdc++6_4.0.2-3_i386.deb
  • mapserver-bin_4.6.1-3_i386.deb
  • mapserver-doc_4.6.1-3_i386.deb

php4-mapscript

Got the package php4-mapscript_4.6.1-4_i386.deb from Unstable, but it is uninstallable because it depends from libapache-mod-php4 (which we do not have, because we run Apache2) or from phpapi-20020918 (which does not exists). Binary repackaged, changing only the depends:

  • libapache-mod-php4 | phpapi-20020918 | libapache2-mod-php4

The Apache module does not load, we have to edit /etc/php4/apache2/php.ini adding a line extension=php_mapscript.so and we have to create a symbolic link:

/usr/lib/php4/20050606/php_mapscript.so -> ../20020429/php_mapscript.so

libpostgis1-pg74

Got the package libpostgis1-pg74_1.0.0-1_i386.deb from Debian Unstable, binary repackaged changing the depends:

  • removed libgeos2
  • libgeos2 (>= 2.1.1) | libgeos2c2
1) , 2)
On debian-gis
tecnica/gps_cartografia_gis/debian_install.txt · Last modified: 2011/08/17 10:03 by niccolo